-ld: library not found for -lGoogleToolboxForMac error

The problem

When trying to build my PhoneGap app in xCode for testing on iOS experienced this error.

-ld: library not found for -lGoogleToolboxForMac error

I came across this link which explained that the error was fixed as of cordova-cli 7.0.0.

The solution

Insert this line into your project's config.xml:

<preference name="phonegap-version" value="cli-7.1.0" />
	

Then, delete your "platforms" directory and finally run phonegap build.

Sam L

12th December 2018 23:19